InDesign – Serienbrief mit Datenzusammenführung und Bedingung erstellen

Immer wieder hatte ich das Problem, die z.B. in Word oder OpenOffice bekannten Bedingungen „if…then…else“ in InDesign irgendwie zu ersetzen, weil es diese dort meines Wissen nach nicht gibt (aktuell CS6 | CC).

Beispiel: Wenn das Feld „Anrede“ gleich „Frau“ ist, dann schreibe „Sehr geehrte Frau“, ansonsten „Sehr geehrter Herr“.

Diesen Sachverhalt löse ich komplett in der Tabelle auf, die mir die Serienbriefvariablen liefert, indem ich die gewünschten Teildaten in einer neuen Spalte zusammenführe. Die Spalte könnte z.B. „AnredeUeberschrift“ heißen und den Inhalt „Sehr geehrte Frau“ enthalten. In InDesign platziere ich dann die Variable „AnredeUeberschrift“ an der entsprechenden Stelle.

Das Verfahren kann man mit allen Varianten durchführen. Damit meine ich die vergleichbaren Probleme mit dem Titel einer Person oder den unterschiedlichen Ansprachen mit Du oder Sie.

Hier mein erstes YouTube-Video zum Thema für euch.

4 Gedanken zu „InDesign – Serienbrief mit Datenzusammenführung und Bedingung erstellen

  1. Jo

    Hallo Maik,

    eine tolle Idee mit den Lernvideos. Eine Sache ist mir aufgefallen: Bei der Anrede schreibt man ja selten den Vornamen mit, d.h. nicht: Sehr geehrte Frau Lieschen Müller, sondern eher „Sehr geehrte Frau Müller“.
    Vielleicht könntest Du das noch ändern, da es sich meiner Meinung nach besser anhört!
    Prima Blog!!
    C.U. on Wednesday!!
    Viele Grüße

    Jo

    Antworten
    1. admin Beitragsautor

      Hallo Jo,
      vielen lieben Dank für deinen Hinweis. Du hast völlig Recht.
      Im Video kann ich das jedoch nicht so leicht rausschneiden. Da es sich vor allem um das Verfahren an sich dreht, hoffe ich auf Verständnis, wenn ich diesen Punkt so belasse.
      Maik Ahrens

      Antworten
  2. Theo Michiels

    Hi Maik,
    danke für deine tolle Video, aber wie bekomme bei Firma das Leerzeichen weg hinter
    Sehr geehrte Damen und Herren ,

    Viele Grüße

    Theo

    Antworten
    1. admin Beitragsautor

      Hallo Theo,
      vielen Dank für deine Anfrage. Ich habe diesen Punkt zur Veröffentlichung ignoriert, aber das geht besser. Die Lösung: Im InDesign-Dokument hatte ich zwischen den beiden Variablen AnredeUeberschrift und AnredeUeName eine Leerstelle und dann das Komma geschrieben. Wenn die zweite Variable nicht befüllt wird, bleibt die Leerstelle vor dem Komma erhalten.
      Das kann man umgehen, indem man die Leerstelle in der Tabelle erzeugt und in InDesign wegfallen lässt.
      Im Feld AnredeUeName schreibt man in die Formel anstatt =WENN(A2=“Firma“;““;I2) dieses =WENN(A2=“Firma“;““;ZEICHEN(160)&I2).
      So wird die Leerstelle praktisch nur erzeugt, wenn der Name auch benutzt wird und fällt bei Firmen weg. Der Befehl ZEICHEN(160) ist ein geschütztes Leerzeichen.
      Viel Erfolg beim Testen.
      Maik

      Antworten

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.